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Blends, Gradients & Mesh

To create shading and modeling using fills and colors, it’s 
important to learn how to work with blends, gradients, 
and mesh. In the history of Adobe Illustrator, blends 
came first, then gradients, then gradient mesh. Each can 
be both simple and very complex. So, we intermingle 
them in the lessons and galleries, even though we discuss 
these features, one at a time, based on the order in which 
they were added to Illustrator.

BLENDS

Think of blends as a way to “morph” one object’s shape 
and/or color into another. You can create blends between 
multiple objects, and even gradients or compound paths 
such as letters. Blends are live, which means you can edit 
the key objects’ shape, color, size, location, or rotation, 
and the resulting in-between objects will automatically 
update. You can also distribute a blend along a custom 
path (see details later in this chapter). 

The simplest way to create a blend is to select the 
objects you wish to blend and choose Object > Blend > 
Make (C+Option+B/Ctrl+Alt+B). The number of steps 
you’ll have in between each object is based on either the 
default options for the tool, or the last settings of the 
Blend Options (discussed in the following section). Adjust 
settings for a selected blend by selecting the blend, then 
double-clicking the Blend tool (or via Objects > Blend > 
Blend Options). 

Another way to create blends between individual 
paths is to point map using the Blend tool. In the past, 
the Blend tool was used to achieve smooth transitions 
between blended objects. However, now that it’s been 
modified, it’s probably best to use it for special morphing 
or twirling effects. To use the point map technique, begin 
by clicking on an anchor point of one object, and then 
on an anchor point of another object. Continue clicking 
on anchor points of any object you want to include in 

“G” Gradient tool“W” Blend tool

The speed of the blend

To control the speed of the blend, 

create the blend and set the num-

ber of blend steps. This creates 

the blend spine, which is editable 

just like any other Illustrator path. 

Using the Convert Anchor Point 

tool, pull out control handles from 

the anchor point at each end of 

the blend spine. By extending or 

shortening the control handles 

along the spine, the speed of the 

blend is controlled. —Derek Mah
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 This is for the TOC, leave it here
Part of this text frame MUST
be on the page for this to work!

“U” Mesh tool

Automatically updating colors

Changing a spot or global color 

definition (see the Drawing & 
Coloring chapter) automatically 

updates blends and gradients 

containing that color. Blends be-

tween tints of the same spot color 

(or a spot color and white) up-

date when changes are made to 

that color, even if the blend isn’t 

“live.” (See David Cater’s “Mini 

Cooper” Gallery in the Advanced 
Techniques chapter for a practical 

application of this technique.) 

—ThoughtForm Design
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the blend. You can also click anywhere on the path of an 
object to achieve random blending effects.

When a blend first appears, it’s selected and grouped. 
If you Undo immediately, the blend will be deleted, but 
your source objects remain selected so you can blend 
again. To modify a key object before or after making a 
blend, Direct-Select the key object first, then use any edit-
ing tool (including the Pencil, Smooth, and Path Eraser 
tools) to make your changes. 

Blend Options 
To specify Blend Options as you blend, use the Blend  
tool (see the point map directions in the previous sec-
tion) and press the Option/Alt key as you click the second 
point. The Blend Options dialog will appear, allowing you 
to change any settings before making the blend. To adjust 
options on a completed blend, select it and double-click 
the Blend tool (or Object > Blend > Blend Options). Open-
ing Blend Options without a blend selected sets the default 
for creating blends in this work session; these Options reset 
each time you restart the program.

•	 Specified Steps specifies the number of steps between 
each pair of key objects (the limit is 1000). Using fewer 
steps results in clearly distinguishable objects; a larger 
number of steps results in an almost airbrushed effect.

•	 Specified Distance places a specified distance between 
the objects of the blend.

•	 Smooth Color allows Illustrator to automatically calcu-
late the ideal number of steps between key objects in a 
blend, in order to achieve the smoothest color transition. 
If objects are the same color, or are gradients or patterns, 
the calculation will equally distribute the objects within 
the area of the blend, based on their size.

•	 Orientation determines how the individual blend objects 
rotate as they follow the path’s curves. Align to Page 
(the default, first icon) prevents objects from rotating as 
they’re distributed along the path’s curve (objects stay 
“upright” as they blend along the curve). Align to Path 

To blend or not to blend...

In addition to blending between 

individual paths, or groups of  

objects, you can blend between 

symbols (see the Brushes & Sym-
bols chapter for more on symbols), 

Live Paint objects, or between 

Point type objects. Some of the 

objects you can’t include in a 

blend are meshes, raster images, 

and type objects that aren’t Point 

type. When blending between ob-

jects containing brushes, effects, 

and other complex appearances, 

Illustrator blends affect options, 

which can help you create inter-

esting animations (see the Web & 
Animation chapter for more on 

exporting animations).—Teri Petit

Efficient blending

To make a blend follow a specific 

path, just select a manually drawn 

path (with no fill or stroke) and 

any objects you want to blend. 

Once you make the blend (Ob-

ject > Blend > Make), the path 

becomes the spine of the blended 

objects. —Jean-Claude Tremblay

To insert objects into a blend

Group-Select a key object and Op-

tion/Alt-drag to insert a new key 

object (the blend will reflow). You 

can also insert new objects by en-

tering Isolation mode (see previ-

ous chapter) or by dragging them 

into the blend in the Layers panel.
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(the second icon).allows blend objects to rotate as they 
follow the path. 

Blends along a path

There are two ways to make blends follow a curved path. 
The first way is to Direct-Select the spine of a blend (the 
path automatically created by the blend) and then use 
the Add/Delete Anchor Point tools, or any of the follow-
ing tools, to curve or edit the path: the Direct Selection, 
Lasso, Convert Anchor Point, Pencil, Smooth, or even the 
Path Eraser tool. As you edit the spine of the blend, Illus-
trator automatically redraws the blend objects to align to 
the edited spine. 

Secondly, you can also replace the spine with a cus-
tomized path: Select both the customized path and the 
blend, and choose Object > Blend > Replace Spine. This 
command moves the blend to its new spine.

You can also blend between pairs of grouped objects. 
If you’re not getting the results you expect, try creating 
your first set of objects and grouping them (C-G/Ctrl-G). 
Now copy and paste a duplicate set (or Option/Alt and 
drag to create a copy of your group). Select the two sets 
of grouped objects and blend choosing Specified Steps as 
the blend option. Once the objects are blended, you can 
rotate and scale them, and use the Direct Selection tool to 
edit the objects or the spine. (To experiment with a pair of 
grouped blends in this way, find the figures at left on the 
Wow! CD as “AaronMcGarry-blends.ai.”)

Reversing, releasing, and expanding blends

Once you’ve created and selected a blend, you can do any 
of the following:

•	 Reverse the order of objects on the spine by choosing 
Object > Blend > Reverse Spine.

 •	Release blends (Object > Blend > Release) removes 
blends, leaving key objects and spines. Hint: Select>Select 
All releases multiple blends simultaneously. 

•	 Expand a blend to turn it into a group of separate, 
editable objects. Choose Object > Blend > Expand.

The ripening tomatoes on a vine, above, was 
created using a variety of blends: the smooth 
color option for the vine, and groups of objects 
blended into each other with Specified Steps 
and a custom S curve “spine” (see Aaron Mc-
Garry’s explanation on the Wow! CD).

Reverse Front to Back

To reverse the order of a blend 

with only two key objects, Direct-

Select one of the key objects and 

choose Object > Arrange, or for 

any blend choose Object > Blend > 

Reverse Front to Back. You can 

also reorder the objects by ex-

panding the Blend in the Layers 

panel and dragging the <path> to 

a new location within the Blend.
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GRADIENTS

Gradients are color fills that seamlessly transition from 
one color into another. Adobe has made some great 
enhancements to gradients, allowing you to work faster 
and more efficiently. Before Illustrator CS4, all gradient 
adjustments had to made within the Gradient panel. Now 
these adjustments can be made on the artboard, directly 
on the gradient itself. When you select an object with a 
gradient and select the Gradient tool, a white bar appears 
across the gradient on the artboard. This bar is called 
the Gradient Annotator (if this bar doesn’t appear you 
may need to turn it on by choosing View>Show Gradi-
ent Annotator [C-Option-G/Ctrl-Alt-G]). Later in this 
section we’ll discuss other gradient features such as the 
Reverse Gradient toggle, Aspect Ratio control, and even 
the ability to reduce the opacity of color stops.

To open the Gradient panel, double-click the Gradi-
ent tool icon on the Toolbox, or choose Window > Gra-
dient. Gradients can be linear or radial (circular from 
the center). If you intend to go back and forth between 
gradient and solid color fills, float your Gradient panel by 
grabbing its tab and dragging it away from the docking 
area. This allows you to have your Swatches and Gradient 
panel open at the same time. Once your Gradient panel 
is floating, you can adjust its size vertically or horizon-
tally by grabbing the end or side of the panel (your cur-
sor becomes a 2-way arrow when on the edge). Hovering 
your cursor over the panel top and clicking collapses your 
panel to an icon; toggling the arrow icon next to “Gradi-
ent” in the tab reduces or expands the panel options.

To apply a gradient to an object, select the object and 
click on a gradient swatch in the Swatches panel, or click 
on the object with the Gradient tool to fill with the last-
used (or default) gradient or double-click the Gradient 
tool (to open the Gradient panel), and click on either the 
the gradient slider or swatch. 

To start adjusting a gradient, first select the gradient 
object, then click on the Gradient tool in the Tool panel, 
which reveals a white annotator bar across your gradient. 

Adding color to your gradient

•	 Double-click the color stop on 

the Gradient Annotator bar, or 

slider bar in the Gradient panel, 

and select a color from the 

Swatches or Color panel.

•	 Drag a swatch from the Color 

or Swatches panel to the gradi-

ent slider until you see a vertical 

line indicating where the new 

color stop will be added.

•	 If the Fill is a solid color, you can 

drag color from the Fill icon at 

the bottom of the Toolbox.

•	 Hold down the Option/Alt key 

to drag a copy of a color stop. 

•	 Option/Alt-drag one stop over 

another to swap their colors.

•	 Click just beneath the Gradi-

ent annotator bar or slider of 

a gradient where the stops are 

to add a new stop (a small “+” 

sign appears next to your cur-

sor when you are in the correct 

location for adding a new stop).

How long can a gradient be?

Click and drag with the Gradient 

tool anywhere in your image 

window; you don’t need to stay 

within the objects themselves.

Making a new gradient

Start by selecting an existing gra-

dient from the Swatches panel 

similar to the one you wish to 

create and then proceed with the 

instructions shown in this chapter 

for adjusting and customizing it.
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As you move your cursor over the annotator it changes 
to a gradient slider, complete with color stops. You can 
customize your own gradients by adding and/or adjusting 
the stops (pointers representing colors) along the lower 
edge of the annotator; adjust the midpoint between the 
color stops by sliding the diamond shapes along the top of 
the annotator (these adjustments can also be made on the 
gradient slider within the Gradient panel). 

Using the gradient Annotator, you’ll be able to make 
many adjustments with precision on your actual illus-
tration. Grab and drag a diamond endpoint to resize or 
rotate your gradient. With a radial gradient, when you 
move your cursor over the gradient, the gradient circum-
ference appears as a dashed line, with a double-walled 
circle on the dashed line to the left allows you to resize 
your gradient while the circle with the black center at the 
top allows you to change the aspect ratio. Use the aspect 
ratio to change the shape of your radial gradient by mak-
ing it elliptical or for adding perspective. Drag the last 
circle at the end of the annotator if you wish to reposition 
the center point of your radial gradient (the smaller most 
outer circle of the two at the end of the annotator bar). 

When you double-click on a stop on the annotator (or 
gradient slider) the Swatches panel appears. The two icons 
on the left side of this panel allow you to toggle between 
the Swatches or Color panel. Color opacity of that selected 
stop is also adjustable from this panel. When an opac-
ity less than 100% is applied to a stop, it’s indicated by 
a small rectangle that hangs from the stop (see stops on 
slider in panel image to the left). This feature can be use-
ful for revealing underlying objects.

You’ll notice that the Gradient panel also accommo-
dates the features found on the gradient annotator plus 
some additional ones. The Gradient fill pop-up menu 
(next to the sample swatch) in the top left corner of the 
panel allows you to choose from or save to a library of 
gradients. Below the swatch is the “Reverse Gradient” 
toggle, which allows you to reverse your gradient (and 
back again) with a single click. The fields below the gra-

The Gradient panel for the candle flame above; 
the color stops with adjusted opacities are
indicated by the additional rectangle below the 
stop. The opacity of the second color stop from 
the left is indicated in the field below the slider.

For the flame in his candle illustration, Aaron 
McGarry created a custom radial gradient

A detail of the candle flame above showing the 
gradient annotator on the flame with color
stops; the flame has an aspect ratio of 40%, an 
angle of 80° and various opacity settings for 
each color stop so that the wick is partially vis-
ible through portions of the flame

Missing Gradient Annotator?

Don’t see the Gradient Annota-

tor? Try View>Show Gradient An-

notator (C-Option-G/Ctrl-Alt-G). 

However, if one gradient is ap-

plied to multiple objects, the an-

notator won’t reliably appear.
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dient Type pop-up are the numerical controls for angle 
and aspect ratio. As with the gradient annotator, you can 
double-click a stop to access the Swatches or Color panel. 
With a stop selected, you can adjust the opacity by enter-
ing a new number into the Opacity field, or adjust the 
slider from the pop-up arrow. Below the Opacity field is 
the “Location” field where you can see, and modify, the 
precise location of a selected stop in relation to the begin-
ning of a gradient. The fields in the Gradient panel also 
provide a numeric level of accuracy for your gradient so 
you can enter a number directly into the field instead of 
using the field slider.

You can apply a gradient to multiple selected objects 
across a unified blend by clicking and dragging with the 
Gradient tool (see lessons in this chapter for detailed 
examples of how to use the gradient tool). To create the 
illusion of a gradient within a stroke, convert the stroke 
to a filled object (Object > Path > Outline Stroke). You can 
use this method to create a “trap” for gradients. 

To turn a gradient into a grouped, masked blend, use 
Object > Expand (see the Advanced Techniques chapter 
for more on masks and masked blends).

The Swatch Libraries menu icon at the bottom 
left of the Swatches panel allows you to access addi-
tional pre-made gradients (also accessible by choosing 
Window>Swatch Libraries>Gradients). Use the Show 
Swatch Kinds menu icon next to it to show only gradient 
swatches.

There are several ways of saving a new gradient. One 
way is by clicking the “new swatch” icon at the bottom of 
the Swatches panel (make sure your gradient is selected); 
this will prompt you to name your new gradient. You can 
also drag and drop the gradient preview from the Gradi-
ent panel to the Swatches panel or to save a gradient from 
within the Gradient panel. Do so by choosing the disk 
icon from the bottom of the Gradient Fill swatch’s pop-
up menu. This save icon is only active for new gradients. 
Note: Aspect ratio and angle information are not saved 
with gradient swatches.

Reset gradients to defaults

After you select an object that 

has an altered gradient angle 

(or highlight), new objects you 

draw will have the same settings. 

The simplest way to “re-zero” 

gradient settings such as angles 

is to have both the Swatches and 

Gradient panels open, and, with 

your selected gradient, select a 

solid color fill from the Swatches 

panel and then click on the slider 

in the Gradient panel. For linear 

gradients, you can type a zero in 

the Angle field. Or, you can use 

the Gradient panel to switch be-

tween the Radial type and Linear 

type and then back again to reset 

a custom angle without removing 

or relocating color stops.

Gradient or Blend?

Gradients and Blends are often 

confused due to the similar results 

both can produce, namely with 

color transitions. However, they 

are very different in nature.

•	 Gradients can only be used as 

fills for paths.

•	 Gradients are either linear or 

radial moving in parallel from 

one side to another, or from a 

center point to the outside.

•	 Blends are morphed paths be-

tween two end paths and so, in 

addition to blending colors, can 

also morph shapes. Blends are 

not restricted to the directional 

confines of Gradients.
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GRADIENT MESH

In this book you’ll find many amazing photorealistic 
images created using gradient mesh. A mesh object is 
an object on which multiple colors can flow in different 
directions, with smooth transitions between specially 
defined mesh points. You can transform a solid or 
gradient-filled object into mesh (you can’t transform 
compound paths into mesh). Once transformed, the 
object will always be a mesh object, so be certain that 
you work with a copy of the original if it’s difficult to 
re-create. 

Transform solid filled objects into gradient mesh 
objects either by choosing Object > Create Gradient 
Mesh (so you can specify details on the mesh construc-
tion) or by clicking on the object with the Mesh tool. 

One way to get a head start in creating a mesh 
object, is to transform an object filled with a gradi-
ent, into a mesh object. To transform a gradient-filled 
object, select Object > Expand and enable the Gradient 
Mesh option. 

Use the Mesh tool to add lines and points to the 
mesh. Select individual points, or groups of points, 
within the mesh using the Direct Selection tool, the 
Lasso tool, or the Mesh tool in order to move, color, 
or delete them. For details on working with gradient 
meshes (including the Warning Tip about printing 
mesh objects), see Galleries and lessons later in this 
chapter, as well as the Advanced Techniques chapter. 
Hint: Instead of applying a mesh to a complex path, try 
to first create the mesh from a simpler path outline, then 
mask the mesh with the more complex path.

Get back your (mesh) shape!

When you convert a path to a mesh, it’s no longer a 

path, but a mesh object. To extract an editable path 

from a mesh, select the mesh object, choose Object > 

Path > Offset Path, enter 0, and press OK. If there are 

too many points in your new path, try using Object > 

Path > Simplify (for more on Simplify see the Drawing 
& Coloring intro). —Pierre Louveaux

Adding rows and columns

To add new rows and columns 

to your mesh, click on the mesh 

object with the Mesh tool (U). To 

add a new mesh row, click on a 

column mesh line. To add a new 

mesh column, click on a row.

Adding color to the mesh

When adding a new mesh point, 

the color currently selected in the 

Swatches panel will be applied 

to the new point. If you want 

the new mesh point to remain 

the color currently applied to the 

mesh object, hold the Shift key 

while adding a new point.

Moving rows and columns

When moving a mesh point, both 

the row and column mesh lines 

intersecting that point will move 

with it. To move a row or column 

mesh line independently, without 

moving the other, hold the Shift 

key while you drag a line. If you 

drag up or down, only the row 

line moves; if you drag left or 

right, only the column line moves.

The amazing photorealistic work with mesh only 
starts in this chapter—don’t miss the additional 
mesh artwork in the Advanced Techniques 
chapter—above is a detail of an illustration by 
Ann Paidrick.
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